install macOS Catalina for unsupported Mac

Your MacBook is not supported macOS Mojave and macOS Catalina versions, here is the instruction to install the latest macOS version on your Mac.

macOS Mojave and macOS Catalina come with a number of great features like Night Shift Mode, smarter Siri assistant and more.

By default, Apple only supports upgrading to macOS Mojave 10.14 or macOS Catalina 10.15 on the following models:

  • MacBook 2015 and later
  • MacBook Air 2012 and later
  • MacBook Pro 2012 and later
  • iMac2012 and later
  • iMac Pro 2017 and later (all models)
  • Mac Pro 2013 and later
  • Mac mini 2012 and late

In fact, if it’s not supported by Apple, your computer should be left in the current macOS version. But due to some reasons, you still want to upgrade your Mac to macOS Mojave 10.14 or macOS Catalina 10.15 version. With macOS Mojave Patcher and macOS Catalina Patcher, you can still upgrade your machines even when it’s no longer supported these two versions. 

However, you should note that macOS Mojave Patcher or macOS Catalina Patcher does not support all models. They just work with the following models:

Supported Models

  • Early-2008 or newer Mac Pro, iMac, or MacBook Pro:
    • MacPro3,1
    • MacPro4,1
    • MacPro5,1
    • iMac8,1
    • iMac9,1
    • iMac10,x
    • iMac11,x(systems with AMD Radeon HD 5xxx and 6xxx series GPUs will be almost unusable when running Catalina.)
    • iMac12,x (systems with AMD Radeon HD 5xxx and 6xxx series GPUs will be almost unusable when running Catalina.)
    • MacBookPro4,1
    • MacBookPro5,x
    • MacBookPro6,x
    • MacBookPro7,x
    • MacBookPro8,x
  • Late-2008 or newer MacBook Air or Aluminum Unibody MacBook:
    • MacBookAir2,1
    • MacBookAir3,x
    • MacBookAir4,x
    • MacBook5,1
  • Early-2009 or newer Mac Mini or white MacBook:
    • Macmini3,1
    • Macmini4,1
    • Macmini5,x (systems with AMD Radeon HD 6xxx series GPUs will be almost unusable when running Catalina.)
    • MacBook5,2
    • MacBook6,1
    • MacBook7,1
  • Early-2008 or newer Xserve:
    • Xserve2,1
    • Xserve3,1

Preparation:

Once you download all files, let’s start installing macOS Catalina on your unsupported mac computers.

How to Install macOS Catalina on Unsupported Mac Computers

Step 1: Format USB with the following information:

  • Name (partition name): macOS Catalina or macOS Mojave or anyname
  • Format (partition format): Mac OS Extended (Journaled)
  • Scheme (partition table format): GUID Partition Map

If your Mac is running High Sierra or higher, and you want to show Scheme, you must click on the red box, chooe Show All Devices > the highest box of the USB as the image below

Step 2: Extarct the macOS Mojave/ Catalina and drag the Install macOS Mojave/Catalina file into the Application folder

Step 3: Run the macOS Catalina Patcher or macOS Mojave Patcher file . 

Step 4: Click on Continue > Continue and it will show up the screen: Select Browse for a copy

Step 5: Select the Install macOS Catalina file or install the copied macOS Mojave into the Application folder 

Step 6: Choose create a bootable Installer > USB Formated above (macOS Catalina). Click on Start > Yes. Enter your Mac password when prompted.

Step 7: Wait for macOS Catalina Patcher to create the installer. This process takes about 10-20 minutes

Step 8: When done, you will see a big green tick on the screen, notifying that your bootable macOS installer volume has been created successfully.

That’s it! Insert your USB into your Mac and install macOS Mojave or Catalina, depending on your favorite version in Recovery mode.

Good luck to all of you

LEAVE A REPLY

Please enter your comment!
Please enter your name here